gpm 1.20.3-1 i Core

Ved næste opdatering vil den nye version af gpm højst sandsynligt komme med følgende fejl:

error: could not prepare transaction
error: failed to commit transaction (conflicting files)
gpm: /usr/lib/libgpm.so.1 exists in filesystem
Errors occurred, no packages were upgraded.

Årsagen til dette problem er at symlinket der peger på /usr/lib/libgpm.so.1 ikke før har tilhørt gpm pakken. Men da symlinket er nødvendig for at mange programmer kører korrekt er det naturligt at det høre ind under gpm pakken og det er altså kort sagt det der sker nu. Dog vil sådan en ændring medfører at man må tvinge opdateringen ind i systemet på følgende måde (skal gøres som root eller med rootrettigheder):

pacman -Syf gpm
pacman -Syu

Det er vigtigt at dette kun gøres ved den pågældende pakke da andet kan ødelægge vigtigt konfigurationer.

Læs mere:

http://archlinux.org/news/391/

Skriv en kommentar

Kopier venligst strengen Rznvcr til nedenstående felt: