Fejl i bash 3.2.025-3

Det er meget beklageligt at der er sket en stor bommert med hensyn til pakken bash version 3.2.025-3. Fejlen er at pakken ikke inkluderer filen /etc/profile hvilket betyder en del fejl hos brugerne som i sidste ende kan betyde et system der ikke længere fungerer.

Da fejlen blev opdaget dagen efter blev der lavet en ny version nemlig 3.2.025-4 som retter op på fejlen. Dog skal det lige noteres at pacman vil give en “fileconflict” ved /etc/profile. Dette er et af de meget få tilfælde hvor der må bruges pacman -Sf for at løse problemet. Måden det gøres på er ganske enkelt at kører disse kommandoer:

pacman -Sy

pacman -Sf bash

Dette kan roligt gøres da filen vil blive taget backup af under installationen af bash. Dog kan det anbefales at tage backup af /etc/profile hvis man har lavet nogle personlige ændringer i filen man helst ikke vil risikere at miste.

Det er klart at denne her slags fejl ikke må ske igen og udviklerne lover også de vil gøres deres bedste for at undgå denne type fejl igen.

Læs mere:

http://archlinux.org/news/369/

Skriv en kommentar

Kopier venligst strengen U2wSiL til nedenstående felt: